How can we improve our products?

Glary Utilities Pro/Software Update Pro falsely flag a program (Firefox) as needing an update.

Glary Utilities Pro/Software Update Pro falsely flag a program (Firefox) as needing an update. Please fix this

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anna Schiffer shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for your letter.

    We are so sorry for the inconvenience.

    In order to understand and solve your issue, we need to ask you first a few questions:

    -Which Glary Utilities version are you using?
    -What is your operating system: win10 32bit or 64bit?

    Could you please explain the issue you have encountered in detail? Screenshots would also be very helpful to understand the problem at a glance.

    Thanks for your cooperation and have a good day!

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anna Schiffer commented  ·   ·  Flag as inappropriate

        I am using Glary Utilities Pro. My operating system is Windows 19 64bit. No need for screenshot. I keep my browser updated. Glary Utilitis Pro doesn’t recognize the update.

      • Anna Schiffer commented  ·   ·  Flag as inappropriate

        On the flip side, Glary Utilities Pro/Software Update Pro missed a program (ccleaner Pro) as needing an update.

      Feedback and Knowledge Base