How can we improve our products?

Software Updater Free V 5.44.0.41 Keeps Wanting Me To Update Adobe Flash

I keep getting notifications after a scan that Adobe Flash needs to be updated from Version: 27.0.0.170 to 28.0.0.137. However, I already have this newer version installed. Fire Fox 58.0.1.

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Lucille shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base